OSPF Version 2 Configuration

Overview

OSPF version 2 is dynamic routing protocol that use to build routing between connected network and remote network. OSPF is smarter than RIP . Many organization, ISP , and banking use OSPF v2 to build local routing for their network infrastructure. It is reliable and scalable with redundancy link for enterprise business. Beside of these advantage, OSPF use more resource to run its routing and maintenance LSA. OSPF is fast convergent than Rip.

Router ID – form of IPv4 act as Router ID which is unique in every router . It was use to elect DR and BDR router in OSPF. ( Ex: 192.168.1.1)

Topology

OSPF Version 2 Configuration

Configuration Task

Task 1: End Devices
  • Assign all IP address to end devices and router interfaces base on topology noted.
Task 2: OSPF v2 Routing
  • Enable OSPF v2 routing.
  • Advertise all connected network on R1.
  • Advertise all connected network on R2.
Task 3: Verify Connectivity
  • Ping from one of PCs to all PCs.
  • Connection should be successfully.

OSPF Version 2 Configuration

R1

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/1
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.3.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.2.0 0.0.0.255 area 0
R1(config-router)#network 192.168.3.0 0.0.0.255 area 0

R2

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.3.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip address 192.168.4.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/1
R2(config-if)#ip address 192.168.5.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#network 192.168.3.0 0.0.0.255 area 0
R2(config-router)#network 192.168.4.0 0.0.0.255 area 0
R2(config-router)#network 192.168.5.0 0.0.0.255 area 0

Verify Connectivity

  • Ping from PC to all PC
  • Connection should be successfully

Leave a Reply