RIP Version 1 Configuration

RIP Version 1 Overview

The original specification of RIP , outlined in RFC 1058, was printed in 1988 and uses classful routing. The periodic routing updates don’t carry subnet info, lacking support for variable length subnet masks (VLSM). This limitation makes it not possible to possess different-sized subnets within a similar network class. In different words, all subnets during a network class should have a similar size. there’ s additionally no support for router authentication, creating RIP susceptible to numerous attacks.

Topology

RIP V ersion 1 Configuration

RIP V ersion 1 Configuration

R1

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/1
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.3.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)# router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#network 192.168.3.0

R2

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.3.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip address 192.168.4.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/1
R2(config-if)#ip address 192.168.5.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#network 192.168.5.0

Verify Connectivity

  • Ping from all PC to other PC
  • Connection should be successfully

Leave a Reply