RIP Version 2 Configuration

RIP Version 2 Overview

Due to the deficiencies of the initial RIP specification, RIP version 2 (RIPv2) was developed in 1993 and last standardized in 1998. It enclosed the flexibility to hold subnet data, therefore supporting egalitarian Inter-Domain Routing (CIDR). to keep up backward compatibility , the hop count limit of fifteen remained. RIPv2 has facilities to totally interoperate with the sooner specification if all should Be Zero protocol fields within the RIPv1 messages are properly mere. additionally , a compatibility switch feature permits fine-grained ability changes.

In an attempt to avoid extra load on hosts that don’t participate in routing, RIPv2 multicast the whole routing table to all or any adjacent routers at the address 224.0.0.9, as against RIPv1 that use broadcast. Unicast addressing remains allowed for special applications.

(MD5) authentication for RIP was introduced in 1997.

Route tags were additionally value-added in RIP version two. This standard permits a distinction between routes learned from the RIP protocol and routes learned from alternative protocols.

Topology

RIP Version 2 Configuration

RIP Version 2 Configuration

R1

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/1
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.3.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)# router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#network 192.168.3.0

R2

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.3.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip address 192.168.4.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/1
R2(config-if)#ip address 192.168.5.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#network 192.168.5.0

Verify Connectivity

  • Ping from PC to any PC
  • Connection should be successfully

Leave a Reply